Back to newton.co
Newton
Status
Interac e-Transfer Planned Maintenance
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
May
24
,
2026
-
09:16
EDT
Investigating
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted
May
24
,
2026
-
02:14
EDT
This incident affected: Funding (e-Transfer Deposits) and Withdrawals (e-Transfer Withdrawals).
×
Subscribe to Incident
Subscribe to updates for
Interac e-Transfer Planned Maintenance
via . You'll receive .