Back to newton.co
Newton
Status
Newton Platform
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Jun
12
,
2025
-
17:25
EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Jun
12
,
2025
-
16:25
EDT
Investigating
A number of our systems are currently impacted by a Google Cloud outage, which is affecting multiple third-party vendors.
Posted
Jun
12
,
2025
-
14:19
EDT
This incident affected: General (Web App, Mobile Apps).
×
Subscribe to Incident
Subscribe to updates for
Newton Platform
via . You'll receive .