Back to newton.co
Newton
Status
e-Transfer services are unavailable
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Nov
11
,
2024
-
23:36
EST
Update
We are continuing to monitor for any further issues.
Posted
Nov
11
,
2024
-
23:18
EST
Update
We are continuing to monitor for any further issues.
Posted
Nov
11
,
2024
-
23:17
EST
Monitoring
A fix is progressively being implemented, we are monitoring for improvements.
Posted
Nov
11
,
2024
-
23:14
EST
Identified
We have identified the root cause, and are working with our service providers to rectify this issue.
Posted
Nov
11
,
2024
-
21:28
EST
Investigating
impartial outage since 8PM ET. we are investigating.
Posted
Nov
11
,
2024
-
20:40
EST
This incident affected: Funding (e-Transfer Deposits) and Withdrawals (e-Transfer Withdrawals).
×
Subscribe to Incident
Subscribe to updates for
e-Transfer services are unavailable
via . You'll receive .