Newton icon logo

Newton

Status

USDC - Trading and Deposits

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Mar 13, 2023 - 10:21 EDT

Monitoring

USDC deposits and trading have been re-enabled.
Posted Mar 13, 2023 - 10:02 EDT

Investigating

USDC trading and deposits have been temporarily suspended until further notice due to unforeseen circumstances. We apologize for any inconvenience this may cause and will keep you updated as we receive more information. Thank you for your patience and understanding during this time.

USDC withdrawals remain open, and we will continue to evaluate the situation and aim to resume USDC trading and deposits as soon as possible.
Posted Mar 10, 2023 - 23:30 EST
This incident affected: Trading (Trading Engine).