Newton icon logo

Newton

Status

UST and LUNC Being Delisted
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 15:50 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 17, 2022 - 12:02 EDT
Identified
LUNC funding has been disabled, and UST funding, trading, and withdrawals have been disabled as we work towards delisting these assets from our platform.
Posted Jun 27, 2022 - 15:54 EDT