Newton icon logo

Newton

Status

e-Transfer Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 22, 2022 - 17:54 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2022 - 17:25 EST
Investigating
e-Transfer withdrawals have temporarily been disabled while we investigate an outage with our payment processor. Users are able to use other fiat or crypto transfer options if possible during this time.
Posted Nov 22, 2022 - 17:08 EST
This incident affected: Withdrawals (e-Transfer Withdrawals).