Newton icon logo

Newton

Status

Crypto Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 10, 2022 - 12:16 EST
Investigating
Users may experience delays when withdrawing cryptocurrency to an external wallet.
Posted Nov 10, 2022 - 11:31 EST
This incident affected: Crypto Withdrawals (All Crypto Withdrawals).