Back to newton.co
Newton
Status
Request Money E-Transfers
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
May
19
,
2026
-
16:08
EDT
Investigating
Users may experience a delay when funding via the "Request Money" e-Transfer method while we investigate an issue.
Posted
May
19
,
2026
-
15:23
EDT
This incident affected: Funding (e-Transfer Deposits).
×
Subscribe to Incident
Subscribe to updates for
Request Money E-Transfers
via . You'll receive .