Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 12, 2025 - 00:30 EST
Scheduled
Interac will be applying critical maintenance to their e-Transfer systems during the planned downtime, and e-Transfers will be unavailable on the Newton platform during this period.
Posted Jan 10, 2025 - 13:51 EST
This scheduled maintenance affected: Funding (e-Transfer Deposits) and Withdrawals (e-Transfer Withdrawals).