Back to newton.co
Newton
Status
E-transfer deposits are inconsistent
Incident Report for
Newton
Resolved
The issue has been resolved.
Posted
Jun
18
,
2025
-
11:07
EDT
Update
The issue has been identified and a fix is being implemented. Please use the 'Request via app' feature for faster deposits during this time.
Posted
Jun
15
,
2025
-
18:39
EDT
Update
The issue has been identified and a fix is being implemented. Please use the 'Request via app' feature for faster deposits during this time.
Posted
Jun
15
,
2025
-
16:24
EDT
Identified
The issue has been identified and a fix is being implemented. Please use the 'Request via app' feature for faster deposits during this time.
Posted
Jun
15
,
2025
-
16:01
EDT
Investigating
E-transfer deposits are temporarily unavailable while we investigate an interruption.
Posted
Jun
14
,
2025
-
22:42
EDT
This incident affected: Funding (e-Transfer Deposits).
×
Subscribe to Incident
Subscribe to updates for
E-transfer deposits are inconsistent
via . You'll receive .