Newton icon logo

Newton

Status

TIA Deposits and Withdrawals

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 17:30 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2025 - 16:58 EST

Investigating

TIA deposits and withdrawals are temporarily unavailable due to an unexpected issue with our wallet provider. TIA is still available for trading, and we will resume deposits and withdrawals as soon as possible.
Posted Nov 24, 2025 - 14:26 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2025 - 12:27 EST

Investigating

TIA deposits and withdrawals are temporarily unavailable due to an unexpected issue with the Celestia node. TIA is still available for trading, and we will resume deposits and withdrawals as soon as possible.
Posted Nov 24, 2025 - 10:11 EST
This incident affected: Crypto Funding (Celestia - TIA) and Crypto Withdrawals (Celestia - TIA).