Newton icon logo

Newton

Status

ERC-20 Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 12:53 EDT
Investigating
Users may experience a delay when withdrawing on the Ethereum network while our wallet provider investigates an issue.
Posted Apr 24, 2024 - 12:14 EDT
This incident affected: Crypto Withdrawals (All Crypto Withdrawals).