Newton icon logo

Newton

Status

Crypto Deposit and Withdrawal Processing Delays
Incident Report for Newton
Resolved
This incident has been resolved.
Posted May 26, 2022 - 17:19 EDT
Monitoring
Our team is also continuing to reprocess and reverse all remaining affected crypto deposits and withdrawals.
Posted May 13, 2022 - 15:19 EDT
Update
We are currently investigating BTC deposit and withdrawal processing delays.

Our team is also continuing to reprocess and reverse all remaining affected crypto deposits and withdrawals.
Posted May 11, 2022 - 14:49 EDT
Update
We are continuing to monitor the status of deposits and withdrawals.
Posted May 10, 2022 - 18:50 EDT
Investigating
Crypto withdrawals sent last night may need to be reversed by our team. We are working to reverse all affected transfers that did not broadcast properly onto the blockchain ASAP.

Some UST and LUNA deposits and withdrawals may also continue to be delayed due to ongoing intermittent issues with the Terra network. Our team is investigating possible fixes on our end.
Posted May 10, 2022 - 17:58 EDT
This incident affected: Crypto Withdrawals (Aave - AAVE, Axie Infinity - AXS, Basic Attention Token - BAT, Bitcoin - BTC, Bitcoin Cash - BCH, Cardano - ADA, Chainlink - LINK, Compound - COMP, Curve DAO Token - CRV, Dai - DAI, Dogecoin - DOGE, Ethereum - ETH, Enjin Coin - ENJ, Litecoin - LTC, LUNC, Maker - MKR, PAX Gold - PAXG, Polkadot - DOT, Polygon - MATIC, QCAD, Solana - SOL, Stellar - XLM, SushiSwap - SUSHI, Synthetix - SNX, TerraUSD - UST, Uniswap - UNI, USD Coin - USDC, Yearn Finance - YFI).