Newton icon logo

Newton

Status

BTC and ETH Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 15:39 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 01, 2024 - 15:33 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 01, 2024 - 15:33 EST
Investigating
Bitcoin and Ethereum withdrawals have been temporarily suspended while we investigate an issue. Any transactions currently pending will be resolved by our Customer Success team.
Posted Feb 01, 2024 - 15:25 EST
This incident affected: Crypto Withdrawals (Bitcoin - BTC, Ethereum - ETH).