Newton icon logo

Newton

Status

FTM and BCH Withdrawals Temporarily Disabled
Incident Report for Newton
Resolved
This incident has been resolved.
Posted May 11, 2022 - 22:48 EDT
Investigating
FTM and BCH withdrawals have been temporarily disabled while we rebalance out hot wallets.
Posted May 11, 2022 - 22:28 EDT
This incident affected: Crypto Withdrawals (Bitcoin Cash - BCH).