Newton icon logo

Newton

Status

Issue Affecting Bitcoin Funding and Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 10:11 EDT
Update
An issue is affecting our wallet partner which is causing problems with Bitcoin funding and withdrawals. Delays may be experienced when performing these actions
Posted Jul 18, 2024 - 15:02 EDT
Investigating
An issue is affecting our wallet partner which is causing problems with Bitcoin funding and withdrawals. We are investigating and will update this page with more information as it comes available.
Posted Jul 18, 2024 - 14:18 EDT
This incident affected: Crypto Funding (Bitcoin - BTC) and Crypto Withdrawals (Bitcoin - BTC).