Back to newton.co
Newton
Status
Bitcoin withdrawals
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Nov
09
,
2023
-
16:42
EST
Identified
An issue affecting Bitcoin withdrawals has been identified and a fix is being implemented.
Posted
Nov
09
,
2023
-
14:15
EST
This incident affected: Crypto Withdrawals (Bitcoin - BTC).
×
Subscribe to Incident
Subscribe to updates for
Bitcoin withdrawals
via . You'll receive .