Newton icon logo

Newton

Status

POL - Polygon
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 25, 2024 - 14:05 EST
Update
POL balances are now displaying as expected. Additionally, withdrawals on the Polygon network as well as trading have been enabled for POL. Deposits remain disabled at this time.
Posted Nov 22, 2024 - 18:49 EST
Investigating
Users may experience a $0 value when viewing their POL holdings following the MATIC to POL migration. Additionally, deposits, trading, and funding of POL remain temporarily disabled. Thank you for your patience as we work to resolve this.
Posted Nov 22, 2024 - 17:52 EST
This incident affected: Crypto Withdrawals (Polygon - POL) and Crypto Funding (Polygon - POL).