Newton icon logo

Newton

Status

User Verification

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 12:00 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 15, 2026 - 11:42 EST

Investigating

Some users may be unable to complete photo ID verification while our verification provider investigates a service outage.
Posted Jan 15, 2026 - 11:26 EST
This incident affected: Verifications.