Back to newton.co
Newton
Status
ADA Staking
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Dec
08
,
2025
-
15:26
EST
Investigating
ADA staking actions have been temporarily disabled while our team investigates an issue.
Posted
Dec
08
,
2025
-
13:29
EST
This incident affected: Staking.
×
Subscribe to Incident
Subscribe to updates for
ADA Staking
via . You'll receive .