Newton icon logo

Newton

Status

e-Transfer Withdrawals Degraded Performance
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 01, 2024 - 16:19 EDT
Investigating
A small number eTransfer withdrawals are experiencing delays in processing. We are investigating the issue urgently, and will update this page with more information as it comes available.
Posted Nov 01, 2024 - 13:48 EDT
This incident affected: Withdrawals (e-Transfer Withdrawals).