Back to newton.co
Newton
Status
e-Transfers
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Feb
03
,
2025
-
15:09
EST
Investigating
Users may experience delays when funding or withdrawing via Interac e-Transfer as we investigate an issue.
Posted
Feb
03
,
2025
-
11:46
EST
This incident affected: Funding (e-Transfer Deposits) and Withdrawals (e-Transfer Withdrawals).
×
Subscribe to Incident
Subscribe to updates for
e-Transfers
via . You'll receive .