Newton icon logo

Newton

Status

SOL Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 21:20 EST
Investigating
SOL withdrawals are temporarily unavailable while we investigate an issue.
Posted Dec 05, 2024 - 21:05 EST
This incident affected: Crypto Withdrawals (Solana - SOL).