Newton icon logo

Newton

Status

Trading service non operational since 2AM ET
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Dec 10, 2024 - 13:11 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2024 - 11:40 EST
Update
A fix has been implemented, we are monitoring for any further issues.
Posted Dec 10, 2024 - 11:40 EST
Identified
We have identified possible root causes, and are addressing these issues.
Posted Dec 10, 2024 - 10:03 EST
Investigating
We are investigating an outage with our trading service.
Posted Dec 10, 2024 - 09:39 EST
This incident affected: Trading (Trading Engine).