Newton icon logo

Newton

Status

Etransfer degraded experience

Incident Report for Newton

Resolved

The issue has been resolved
Posted May 10, 2026 - 11:50 EDT

Update

We are continuing to investigate this issue.
Posted May 10, 2026 - 11:49 EDT

Investigating

We are currently investigating this issue.
Posted May 10, 2026 - 11:17 EDT
This incident affected: Funding (e-Transfer Deposits) and Withdrawals (e-Transfer Withdrawals).