Newton icon logo

Newton

Status

Increased Error Rates on BTC Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted May 13, 2022 - 00:42 EDT
Update
We are continuing to monitor the status of BTC withdrawals
Posted May 12, 2022 - 10:00 EDT
Investigating
Some BTC withdrawals are currently failing to broadcast properly onto the blockchain. Affected withdrawals will be reversed by our team.
Posted May 11, 2022 - 18:16 EDT
This incident affected: Crypto Withdrawals (Bitcoin - BTC).