Newton icon logo

Newton

Status

Service Degradation
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 21:50 EST
Monitoring
We have identified the root cause. It has been addressed and we are monitoring for any further issues.
Posted Nov 07, 2024 - 21:44 EST
Update
We are continuing to investigate this issue.
Posted Nov 07, 2024 - 21:33 EST
Update
We are continuing to investigate this issue.
Posted Nov 07, 2024 - 21:07 EST
Investigating
We are currently investigating a drop in service quality. We are investigating.
Posted Nov 07, 2024 - 21:05 EST
This incident affected: Funding (e-Transfer Deposits, Wire Transfers), Withdrawals (e-Transfer Withdrawals, EFT Withdrawals), Trading (Trading Engine, Limit Orders), General (Web App, Mobile Apps, 2FA - Account Access), Crypto Withdrawals (All Crypto Withdrawals), and Verifications.