Newton icon logo

Newton

Status

Crypto Withdrawals

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Sep 01, 2025 - 23:27 EDT

Monitoring

A fix has been implemented and we are monitoring results.
Posted Aug 31, 2025 - 16:45 EDT

Investigating

Crypto withdrawals have been temporarily disabled while we investigate an issue with our wallet provider.
Posted Aug 31, 2025 - 12:25 EDT
This incident affected: Crypto Withdrawals (All Crypto Withdrawals).