Newton icon logo

Newton

Status

BTC Withdrawals

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Nov 20, 2022 - 18:58 EST

Identified

The issue has been identified and a fix is being implemented by our wallet partner.
Posted Nov 20, 2022 - 16:46 EST

Update

Our wallet partner is actively investigating the issues with transactions and balance updates on BTC blockchain.
Posted Nov 20, 2022 - 15:12 EST

Investigating

BTC withdrawals have been temporarily disabled while our wallet partner is investigating increased error rates for BTC withdrawals. Failed withdrawals will be automatically reversed.
Posted Nov 20, 2022 - 14:37 EST
This incident affected: Crypto Withdrawals (Bitcoin - BTC).