Newton icon logo

Newton

Status

Staking Activity

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 18:06 EST

Investigating

We are currently investigating an issue that’s preventing staking entries from showing on the mobile activity page. Please note this is only a display issue, all staking actions and rewards remain fully active and unaffected.
Posted Nov 21, 2025 - 17:39 EST
This incident affected: Staking.