UST: Trading and Funding Unavailable
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Jun 27, 2022 - 15:52 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 27, 2022 - 15:52 EDT
Identified
Trading (buying and selling) and funding is currently unavailable for UST.
Posted May 15, 2022 - 14:23 EDT
This incident affected: Crypto Funding (Terra USD - UST).