Back to newton.co
Newton
Status
Increase in Interac e-Transfer Withdrawal reversals
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Dec
02
,
2024
-
17:11
EST
Investigating
We are currently experiencing an increased delay in processing withdrawals and are investigating.
Posted
Dec
02
,
2024
-
10:07
EST
This incident affected: Withdrawals (e-Transfer Withdrawals).
×
Subscribe to Incident
Subscribe to updates for
Increase in Interac e-Transfer Withdrawal reversals
via . You'll receive .