Newton icon logo

Newton

Status

E-Transfers

Incident Report for Newton

Resolved

This incident has been resolved.
Posted May 02, 2025 - 21:58 EDT

Investigating

E-transfer deposits and withdrawals are temporarily unavailable while our banking partner investigates a service interruption.
Posted May 02, 2025 - 18:55 EDT
This incident affected: Funding (e-Transfer Deposits) and Withdrawals (e-Transfer Withdrawals).