Newton icon logo

Newton

Status

USDC Polygon

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 17:38 EDT

Investigating

USDC withdrawals on the Polygon network have been temporarily suspended. All other supported USDC networks remain enabled.
Posted Jul 14, 2025 - 14:53 EDT
This incident affected: Crypto Withdrawals (USD Coin - USDC).