Back to newton.co
Newton
Status
INJ Limit Orders
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Apr
02
,
2024
-
10:24
EDT
Investigating
INJ Limit Orders are temporarily unavailable while we investigate an issue.
Posted
Mar
31
,
2024
-
10:56
EDT
This incident affected: Trading (Limit Orders).
×
Subscribe to Incident
Subscribe to updates for
INJ Limit Orders
via . You'll receive .