Back to newton.co
Newton
Status
Push Notifications
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Oct
07
,
2025
-
12:22
EDT
Investigating
Users may not receive push notifications as expected while our provider investigates an issue.
Posted
Oct
07
,
2025
-
11:34
EDT
This incident affected: General (Mobile Apps).
×
Subscribe to Incident
Subscribe to updates for
Push Notifications
via . You'll receive .