Newton icon logo

Newton

Status

Crypto Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted May 18, 2023 - 23:42 EDT
Investigating
Users may experience delays when withdrawing cryptocurrency while our wallet provider works to resolve an outage. Fiat withdrawal methods remain available, and all crypto withdrawals will be either completed or returned to users' Newton accounts.
Posted May 18, 2023 - 22:09 EDT
This incident affected: Crypto Withdrawals (All Crypto Withdrawals).