Newton icon logo

Newton

Status

New Limit Order Creation is Disabled
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 10:27 EST
Identified
We are hard at work building a new limit order engine to better serve our customers in the new year. Existing limit orders will continue to fill as usual.
Posted Nov 30, 2023 - 16:34 EST
This incident affected: Trading (Limit Orders).