Newton icon logo

Newton

Status

e-Transfer Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Aug 20, 2024 - 14:10 EDT
Investigating
Users may notice a temporary delay in receiving e-Transfer withdrawals as we work to integrate a new banking partner. If you have not received your transfer after 1 hour, please get in touch with our support team for further assistance
Posted Jul 24, 2024 - 16:57 EDT
This incident affected: Withdrawals (e-Transfer Withdrawals).