Newton icon logo

Newton

Status

Base network deposits
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 10:26 EDT
Identified
Base network deposits for Ethereum (ETH_Base) and USD Coin (USDC_Base) are temporarily disabled as we work through an issue. We will re-enable once resolved.
Posted Apr 25, 2024 - 17:09 EDT
This incident affected: Crypto Funding (Ethereum - BASE, USD Coin - BASE).