Back to newton.co
Newton
Status
USDC-AVAX Withdrawals
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Aug
13
,
2026
-
10:56
EDT
Investigating
USDC withdrawals on the Avalanche network have been temporarily disabled.
Posted
Aug
12
,
2026
-
14:52
EDT
This incident affected: Crypto Withdrawals (USD Coin - USDC).
×
Subscribe to Incident
Subscribe to updates for
USDC-AVAX Withdrawals
via . You'll receive .