Newton icon logo

Newton

Status

Crypto Withdrawals

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 12:21 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2026 - 12:19 EST

Investigating

Users may intermittently experience withdrawal failures while our wallet provider investigates an issue. Any failed withdrawals will be returned to users’ Newton accounts.
Posted Jan 20, 2026 - 12:10 EST
This incident affected: Crypto Withdrawals (All Crypto Withdrawals).