We are continuing to monitor for any further issues.
Posted Nov 13, 2024 - 08:46 EST
Monitoring
We are seeing intermittent delays with processing e-Transfer withdrawals. If you are affected, please wait a few minutes before reattempting your withdrawal.
Posted Nov 12, 2024 - 23:52 EST
This incident affected: Withdrawals (e-Transfer Withdrawals).