Newton icon logo

Newton

Status

SUI Deposits and Withdrawals

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 17:49 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2026 - 15:53 EST

Investigating

Due to an unexpected issue with the SUI blockchain, deposits and withdrawals of SUI are temporarily unavailable.
Posted Jan 14, 2026 - 15:23 EST
This incident affected: Crypto Funding (Sui - SUI) and Crypto Withdrawals (Sui - SUI).