Newton icon logo

Newton

Status

Trading
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Feb 07, 2023 - 12:02 EST
Update
Trading has been disabled until further notice for the following assets: DASH, ETC, ZEC, ALICE, QCAD, RNDR, MASK, HOT, SRM, and WBTC.

On the Newton USA platform, trading has been temporarily disabled for the following assets: AAVE, ALGO, AVAX, BAT, DAI, ETHW, FTM, LINK, SHIB, USDT, XLM, and XTZ.
Posted Nov 14, 2022 - 23:49 EST
Update
Limit order functionality has been re-enabled for BTC, ETH, SOL, DOGE, ADA, SHIB, MATIC, LTC, DOT, BCH and USDC. Market orders remain fully functional for most assets.
Posted Nov 14, 2022 - 17:28 EST
Update
We are continuing to investigate this issue.
Posted Nov 11, 2022 - 11:27 EST
Investigating
Limit order functionality has been temporarily suspended. Users that have an open limit order will have that order automatically cancelled. Market orders remain fully functional for most assets.
Posted Nov 10, 2022 - 23:25 EST
This incident affected: Trading (Trading Engine, Limit Orders).