Newton icon logo

Newton

Status

Solana Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Jul 13, 2022 - 10:22 EDT
Investigating
Users may experience intermittent errors when initiating Solana withdrawals. Any funds affected will be returned by our support team.
Posted Jun 15, 2022 - 14:33 EDT
This incident affected: Crypto Withdrawals (Solana - SOL).