Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 10, 2025 - 09:55 EDT
Scheduled
The Polygon main-net will perform an upgrade on July 10th, 2025 at 10:00 AM ET. During the upgrade period, Polygon network deposits and withdrawals may be delayed.
Posted Jul 09, 2025 - 10:31 EDT
This scheduled maintenance affected: Crypto Funding (Polygon - POL) and Crypto Withdrawals (Polygon - POL).