Newton icon logo

Newton

Status

USDC Withdrawals on AVAX
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 10:46 EST
Identified
USDC withdrawals on the Avalanche C-Chain are temporarily unavailable.
Posted Oct 03, 2024 - 10:12 EDT
This incident affected: Crypto Withdrawals (USD Coin - USDC).