Back to newton.co
Newton
Status
e-Transfer Withdrawals
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Sep
14
,
2023
-
16:25
EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Sep
14
,
2023
-
15:14
EDT
Investigating
e-Transfer withdrawals have temporarily been disabled while we investigate an issue with our payment processor.
Posted
Sep
14
,
2023
-
14:11
EDT
This incident affected: Withdrawals (e-Transfer Withdrawals).
×
Subscribe to Incident
Subscribe to updates for
e-Transfer Withdrawals
via . You'll receive .