Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 30, 2025 - 11:45 EDT
Scheduled
Hedera will be upgrading the Hedera mainnet on May 30, 2025 at 12 PM EDT. Newton will halt all deposits and withdrawals on the Hedera blockchain, as the network may be disrupted during the upgrade. HBAR trading will not be affected.
Posted May 28, 2025 - 15:00 EDT
This scheduled maintenance affected: Crypto Funding (Hedera Hashgraph - HBAR) and Crypto Withdrawals (Hedera Hashgraph - HBAR).